โครงการ WordPress ประกาศปรับเวอร์ชันขั้นของซอฟต์แวร์ที่ต้องการใช้งาน โดยบังคับให้ใช้ PHP 5.6 ขึ้นไปและ MySQL 5.5 ขึ้นไป มีผลเดือนเมษายน 2019

เว็บไซต์ที่ยังอยู่กับ PHP 5.5 จะยังได้รับอัพเดตแพตช์ความปลอดภัยจาก WordPress ต่อไป แต่จะไม่สามารถอัพเกรดเป็น WordPress รุ่นใหญ่รุ่นใหม่ได้อีกแล้ว (คาดว่า WordPress 5.1 ที่จะออกช่วงนั้น คงจะเป็นตัวสุดท้ายที่ซัพพอร์ต PHP 5.5)

โครงการ WordPress ระบุว่าตอนนี้มีเว็บไซต์ที่รัน WordPress ประมาณ 85% ใช้งาน PHP 5.6 ขึ้นไปเรียบร้อยแล้ว และ 98.5% ใช้งาน MySQL 5.5 ขึ้นไป

ทางโครงการยังระบุว่าการซัพพอร์ต PHP 5.6 จะมีอายุค่อนข้างสั้น และมีแผนจะขยับเวอร์ชันขั้นต่ำเป็น PHP 7 ในเดือนธันวาคม 2019

PHP 5.x หมดระยะซัพพอร์ตจากโครงการ PHP ไปตั้งแต่สิ้นปี 2018 นั่นแปลว่าต่อให้ใช้ WordPress รุ่นล่าสุดบน PHP 5.6 ก็มีโอกาสจะถูกโจมตีจากช่องโหว่ของ PHP ได้ ดังนั้นถ้าไม่ติดขัดอะไรก็ควรอัพเกรดเป็น PHP 7.x กันได้เลย

ที่มา – WordPress

No Description


Source: Blognone

error: Content is protected !!
preloader